Tugger the SLUGger!SLUG Mailing List Archives

[SLUG] 24h viewe in Evolution


Hi all,

today I did some searching and I am not sure in how far this would be a
'good' workaround. I hope someone can comment on this!

So I searched for Evolution 24h time format setting bug. There are quite
a few out there on launchpad [1] and on gnome bugs [2] as well.
But from what I read this problem has been around for quite a while and
is still not fixed. I am not a programmer but it seemed to me the
programmer 'blamed' it always on something else.

Anyway my Evolution gives me 12h time formats although everything else
on my system is set to 24h (even the Evolution calendar).

From reading the bugs I understand that it has to do with the local
settings and in how far the programs respect them.

As you might assume my locals are en_AU
$ locale
LANG=en_AU.UTF-8
LC_CTYPE="en_AU.UTF-8"
LC_NUMERIC="en_AU.UTF-8"
LC_TIME="en_AU.UTF-8"
LC_COLLATE="en_AU.UTF-8"
LC_MONETARY="en_AU.UTF-8"
LC_MESSAGES="en_AU.UTF-8"
LC_PAPER="en_AU.UTF-8"
LC_NAME="en_AU.UTF-8"
LC_ADDRESS="en_AU.UTF-8"
LC_TELEPHONE="en_AU.UTF-8"
LC_MEASUREMENT="en_AU.UTF-8"
LC_IDENTIFICATION="en_AU.UTF-8"
LC_ALL=


As a workaround I can start Evolution from the commandline with 
$ export LC_TIME=en_DK.UTF-8 && evolution
and the mails are listed in 24h format.

Now my question!? can I simply put the above command into my evolution
button? or will this break stuff? 
Or maybe there is another solution...

Thanks,

Seb

[1]
https://bugs.launchpad.net/ubuntu/+source/gnome-control-center/+bug/48128
[2] http://bugzilla.gnome.org/show_bug.cgi?id=567870 or
http://bugzilla.gnome.org/show_bug.cgi?id=350825 

Attachment: signature.asc
Description: This is a digitally signed message part