Tugger the SLUGger!SLUG Mailing List Archives

[SLUG] gcc version mismatch for VMWare


After doing a vanilla apt-get upgrade, and then vmware-config.pl I got the following message:

Your kernel was built with "gcc" version "4.2.3", while you are trying to use
"/usr/bin/gcc" version "4.2.4". This configuration is not recommended and
VMware Server may crash if you'll continue. Please try to use exactly same
compiler as one used for building your kernel. Do you want to go with compiler
"/usr/bin/gcc" version "4.2.4" anyway? [no]


There are some suggestions on Ubuntu forums to simply say "yes" and everything works anyway. Does anyone have any thoughts about this?

root@david:~# ls -l /usr/bin/gcc
lrwxrwxrwx 1 root root 7 2008-08-24 17:37 /usr/bin/gcc -> gcc-4.2
root@david:~# ls /usr/bin/gcc*
/usr/bin/gcc  /usr/bin/gcc-4.2  /usr/bin/gccmakedep


regards,

David