Tugger the SLUGger!SLUG Mailing List Archives

Re: [SLUG] Firefox & javascript


You probably would need to specify the site - as it probably is a
matter of bad jasvascript code that someone more knowledgable than me
could comment on. I know from my iPaq (PDA) running Windows Mobile,
many sites buttons just don't work. My presumption has been that IE on
Windows Explorer only has a subset of the standard Javascript
functionality. I am guessing it probably also applies to your choice
of Linux powered web browsers.

I would have thought that the number of users now trying to browse
from phone-like and PDA-like devices would have driven web framework
and web developers to think more about a diverse userbase, but they
still seem to cater for only the top 2 or 3 browser platforms and
think everyone is running a cinematic widescreen. (And that doesn't
even talk about accessibility issues for screen readers, different
languages, etc)

On Thu, Mar 13, 2008 at 11:40 AM, Alan L Tyree <alan@xxxxxxxxxxxxxx> wrote:
> Can anybody explain this to me? I'm using Debian Etch.
>
>  I connect to a commercial site that uses javascript "buttons" to
>  initiate searches. With Iceweasel, Epiphany and Galeon, they don't
>  work. With Opera they work just fine.
>
>  They used to work with Iceweasel - I don't know if I changed any
>  settings or not. The javascript is activated in the preferences and
>  allowed to do anything in the "Advanced" options.
>
>  Driving me nuts. Any suggestions appreciated.
>
>  Thanks,
>  Alan
>
>  --
>  Alan L Tyree                    http://www2.austlii.edu.au/~alan
>  Tel:  04 2748 6206              Fax: +61 2 4782 7092
>  FWD: 615662
>  --
>  SLUG - Sydney Linux User's Group Mailing List - http://slug.org.au/
>  Subscription info and FAQs: http://slug.org.au/faq/mailinglists.html
>



-- 
Regards, Martin

Martin Visser