Tugger the SLUGger!SLUG Mailing List Archives

Re: [SLUG] CUPS!!


Graham Smith wrote:
On Wed, 2 Nov 2005 16:13, Phil Scarratt wrote:

Hi

Anyone got any good howto's on CUPS or links? I'm struggling to come up
with useful google search terms so google's getting me nothing although
I am sure the answer is out there somewhere. My problem is that I have a
printer installed on CUPS on a linux box (RHEL4 - Centos). I need to
install that printer on a Window$ box. Seems to install OK, and connect
and print, but nothing comes out the printer. Even the cups web printer
admin page on the linux box says that the job completed, but nothing
comes out the printer. I can print a test page from the local linux box
and it works OK. I've tried setting loglevel to debug and debug2 to no
avail (well probably I'm missing something). It's got me stumped.
Permissions seem to be OK. The printer just never gets the data.

I've also got problems printing to it from a different linux box
(Ubuntu), which doesn't work either, but I think that's a problem with
the Ubuntu machine as it doesn't even reach the Centos machine. I'm
still plugging away at that one...

Anyone got any links or clues at all?

Fil


Your first problem I think can be solved by altering /etc/mine.convs and /etc/mine.types to enable raw printing as follows


<SNIP>

Already have that configured.



The other problem is that on the ubuntu system you must edit the /etc/client.conf file and add in the IP address or servername of the Cups server. I prefer to use the IP address instead of relying on the /etc/hosts.

# ServerName: the hostname of your server.  By default CUPS will use the
# hostname of the system or the value of the CUPS_SERVER environment
# variable.  ONLY ONE SERVER NAME MAY BE SPECIFIED AT A TIME.  To use
# more than one server you must use a local scheduler with browsing
# and possibly polling.
#

#ServerName myhost.domain.com
ServerName 192.168.20.20


Ahhh yes, I hadn't done this. This has changed things but still no go, possibly due to the browsing configuration you mention below...will take a look.

You may have to alter the browsing section of /etc/cups.conf on your Cups server, by adding in the correct address range that is allowed to connect to the server. The file is very well commented in this area.

Also it is always helpfull to look at the logs in /var/log/cups/ and see what it is complaining about.

Looking through the logs as we speak.





Thanks

--
Phil Scarratt
Draxsen Technologies
0403 53 12 71
--
www.getfirefox.com