SLUG Mailing List Archives
[SLUG] CUPS - roll-back to earlier version [Debian]
- To: SLUG <slug@xxxxxxxxxxx>
- Subject: [SLUG] CUPS - roll-back to earlier version [Debian]
- From: James Gray <james_gray@xxxxxxx>
- Date: Tue, 01 Jun 2004 11:53:00 +1000
- User-agent: Mozilla Thunderbird 0.6 (X11/20040528)
-----BEGIN PGP SIGNED MESSAGE-----
Attention Debian Guru's,
I did a bad, bad thing. This lappy is running Debian Unstable (Sarge)
and it got it's monthly "apt-get dist-upgrade" today. I noticed a few
packages were held back and decided I'd attempt a "manual" update on
those after the 113 packages were upgraded (mostly XFree86 stuff).
So here I go with removal of the held back stuff:
#apt-get remove cupsys cupsys-client gs-esp libcupsimage2 \
~ libcupsys-dev pciutils
So far so good - everything gone. Now reinstall it all....
#apt-get install cupsys cupsys-client gs-esp libcupsimage2 \
~ libcupsys-dev pciutils
pciutils went OK but I now have hosed CUPS and I'm unable to re-install!
~ Ooops. How the heck to I roll back to the previous (working) version???
Here's the details about what apt thinks:
# apt-get install cupsys
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
Since you only requested a single operation it is extremely likely that
the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
~ cupsys: Depends: libcupsimage2 (>= 1.1.19final-1) but it is not going
~ to be installed
~ Depends: libcupsys2-gnutls10 (>= 1.1.20final-1) but it is not
~ going to be installed
~ Depends: libcupsys2-gnutls10 (= 1.1.20final+cvs20040330-4) but
~ it is not going to be installed
~ Depends: gs-esp but it is not going to be installed
E: Broken packages
Oh dear :( I've tried including the stable repositories then using:
apt-get -t stable cupsys = same result.
apt-get -t woody cupsys = same result.
On a side note - why are the dependencies referring to different
versions of "libcupsys2-gnutls10"?? If I try to install just
"libcupsys2-gnutls10" the dependency matrix means that all my
KDE+XFree86 stuff is also hosed (WTF?). Any ideas??
-----BEGIN PGP SIGNATURE-----
Version: GnuPG v1.2.4 (GNU/Linux)
Comment: Using GnuPG with Thunderbird - http://enigmail.mozdev.org
-----END PGP SIGNATURE-----