Tugger the SLUGger!SLUG Mailing List Archives

[SLUG] Rhythmbox -> GStreamer osssink-> Alsa -> snd-intel8x0.. Something here is crackling...


Hey all,

Been playing with trying to get Rhythmbox running on Debian Testing. It's not been going oh so well... :)

Basically, the problem is that as soon as I try to play something in rhythmbox the song starts to crackle.

Now, at the moment I'm using the osssink as alsasink gives me the following error message.

$ gst-launch filesrc location=01.Kielbasa.ogg ! vorbisfile ! alsasink
INFO (10091: 0) Initializing GStreamer Core Library version 0.6.4
INFO (10091: 0) CPU features: (00000000) MMX SSE
INFO (10091: 0) registry: loaded global_registry in 0.312519 seconds
          (/var/lib/gstreamer/0.6/registry.xml)
GStreamer-INFO: 0 live buffer(s)
GStreamer-INFO: 0 live bufferpool(s)
GStreamer-INFO: 0 live event(s)
RUNNING pipeline
Opening alsa device "default" for playback...
Preparing channel: (null) 44100Hz, 2 channels
ALSA lib pcm_hw.c:370:(snd_pcm_hw_sw_params) SNDRV_PCM_IOCTL_SW_PARAMS failed: Invalid argument

** (process:10091): WARNING **: could not set sw_params: Invalid argument
pipeline doesn't want to play

And I know (well, think I know..) that the Alsa OSS emulation is working correctly (muine, xmms, mplayer all work with OSS stuff).

So. What's happening? Does anyone know? I've looked around for similar problems, but haven't found them.

Running Debian Testing, with alsa-modules-2.4.22-1-686 and kernel-image 2.4.22-1-686.

Thanks,
Jordan