Tugger the SLUGger!SLUG Mailing List Archives

[SLUG] Next problem ...


> You could try unloading and reloading the scsi module(s).

Thanks to Terry Collins for that.  It worked a treat!

However, I now have another problem that I've not seen before, so I'm guessing 
it has something to do with having reloaded those modules.

To test that the CD was burnt OK, I mounted it in the drive I normally use as 
a CD reader (which happens to be IDE, so I'm not sure why the SCSI modules 
have anything to do with the problem; it's just the only thing I can think of 
that's changed).

The CD worked fine.  I was able to umount it fine.  However, when I tried to 
eject the CD by hand it seems to be locked.  Trying to use "eject /dev/cdrom" 
gave me the error "eject: unable to eject, last error: Invalid argument".

Any ideas?  By the way, I tried reloading the CD-ROM module ... who says you 
can't teach an old dog new tricks; or should that be "to a little boy with a 
hammer"? :-) ... but that didn't help.

Is there some way to unlock a CD device the kernel thinks is busy?

Thanks in advance,

Harry O.