Tugger the SLUGger!SLUG Mailing List Archives

RE: [SLUG] Re. Debian birth pangs: mail and Lilo ...


Thanks.

	When the install of Debian 2.2.r3 crashed twice at exactly the same place
(X config) I decided that there must be a bug possibly due to download
corruption and reverted to 2.2.r2 which I succeeded with today. I followed
your advice re. 'apt-get dist-upgrade -u' and 'apt-get install mutt' .....
according to the messages there was no need to upgrade and the mutt install
was to good to be true. I did the same with mozilla (M18) but found that it
sat in the top leftrner in an area the size of the Gnome terminal without
maximising - nor did the terminal. I hope it gets better.

	I also tried apt-get with StarOffice 5.2 without success. Neither 'soffice'
nor 'StarOffice' worked. I know it can be downloaded from
http://www.sun.com/staroffice - but surely apt-get does it better - is it
part of the 2.2.r2 distribution ?

Re. "you have only just begun" - I'm always keen to learn something new.

Cheers,

Adam Bogacki.
afb3@xxxxxxxxxxxxx

-----Original Message-----
From: David Kempe [mailto:dave@xxxxxxxxxxxxxxxxxx]
Sent: 19 May, 2001 08:49 AM
To: Adam F. Bogacki; Craige McWhirter
Cc: Slug@Slug. Org. Au
Subject: Re: [SLUG] Re. Debian birth pangs: mail and Lilo ...


> I've edited Lilo so that (I think) it works - a few minutes ago - but when
> installing 2.2.r3, X Windows refused to load which is ironic because I had
> it (and Gnome) running under 2.2.r2. I'll try setting it up with
> 'xf86config' when I have time, otherwise I'll re-run the install process.

Have you got X installed?
you seem to be forgetting apt-get.
apt-get and apt-cache are your friends. None of this downloading mutt from
the mutt website!
just apt-get install mutt
if you have added the cdroms to your /etc/apt/sources.list then it will get
it off the cd.
if you have commented out the http and ftp lines in your sources.list then
it will get it off the net.
apt-cache will search the list of available packages for the search string
you specify. - it gives you the package name to install.

> My mail system is OK. PPP and exim were configured during installation but
> I was sad there was no Mutt included with the base installation or the
> network software package. I'll check the CD's, otherwise I'll download
from
> www.mutt.org.


> One thing which worries me is that a number of device drivers did not
> install, specifically lp (printer) and none of the CD-ROM ones. This
> happened under both 2.2r2 and 2.2r3 .... I am not sure if this is a bug or
> if there is something I am missing.

You are missing apt-get !!! :)

>There were no parameters involved with
> 'lp' so it could be a software problem, fixable (I hope) by downloading
the
> appropriate driver from the Epson website.
>
> Similarly, a number of software packages did not install in the final part
> due to dependency and other problems which the program suggested could be
> fixed by running the install process - again (!). These, however, did not
> seem critical ...

apt-get install mutt will install mutt but also will re-run any packages
that are not fully installed.
this generally cleans up any mess left behind.
you also may want apt-get dist-upgrade -u which will download any packages
that are dependencies also.


> I have to admit that the more I see of Debian, the more I appreciate it.

You have only just begun!


dave