Tugger the SLUGger!SLUG Mailing List Archives

[SLUG] About those RTL8139 network cards... :P


On Thu, 15 Feb 2001, I wrote:

> All I get are timeout errors with both the D-link and another 
> (cheaper) RTL8139 card. And with both 2.2.16 (or whatever Debian Potato
> r0 comes with) and 2.4.0. Has anyone had any luck with these cards?

Oops :P
This discussion got me to take another look at the card(s). I downloaded
Donald Becker's tools, in Debian unstable/sid as nictools-nonpci and
nictools-pci.

It seemed it was a stupid IRQ problem. I guess PCI isn't totally idiot
proof. See, ages ago I had disabled the printer port on this motherboard
when I was satisfied with my printer working over USB. I had also set
IRQ 7 as "PnP/PCI" in the BIOS PnP setup screen. It happened that both the
RTL8139 cards were getting assigned IRQ 7 (and probably another network
card now that I think about it...).

So last night I enabled the printer port and set IRQ 7 back to "Legacy" in
the BIOS. Bingo. The card worked OK then.

So...um...I guess I have to take back any ill-will I attributed to RealTek
and 8139-based network cards. Sorry, my bad :P

> I thought my newly-acquired network gear was broken until I brought the
> SparcStation LX home and it worked straight away - My trusty 2 year-old
> Tulip was the only other working card I had!

Yeah, and now I have to figure out how to get the Tulip card to talk 100Mb
to my 10/100 ethernet switch. The D-link card does it OK, although I 
couldn't force it to do 10Mb.

My bad,
bye

-- 
8<--------8<--------8<--------8<--------8<--------8<--------8<--------
Ian Tester   *8)#          \7\    LINUX: because geeks will find a way
imroy@xxxxxxxxxxxxxxx       \7\      http://www.zipworld.com.au/~imroy