Tugger the SLUGger!SLUG Mailing List Archives

Re: [SLUG] Compile errors with Gnome orbit packages


On Sun, Nov 18, 2001 at 02:07:24PM +1100, Simon Wong wrote:
> On Sun, 2001-11-18 at 10:38, Daniel Stone wrote:
> 
> > Try CFLAGS="-I/usr/include/orbit-1.0" make.
> 
> Thanks.  I thought that ./configure would work that out but apparently
> it is having trouble in this pack.

Over the past couple of months there have been quite a number of changes
about here the GNOME 1 header files are installed (a lot are now
installed in a 'foo-1.0' directory, rather than just 'foo'). This is so
that they can be installed alongside the GNOME 2 packages without
clashes happeningi, such as the wrong header file being sucked into a
GNOME 2 package's build.

I would expect to see problems like the one you're having (incorrect -I
flags) for a while yet as other packages catch up to the change. If, for
example, the 'foo' package maintainer has not upgraded their core
libraries for a while, they wouldn't realise the change had occurred
until the bug reports come flooding in (unless they were following a few
key mailing lists).

So, the short version is: please report the bug to the maintainer (via
their approved bugzilla or smoke signals or whatever) so that they can
make adjustments in the future. As I said, not everybody will be aware
of the change. Tracking all of the schemes from a few different versions
over half a dozen distros is _hard_!

Here ends the annual "be nice to maintainers" sermon. :)

Cheers,
Malcolm

-- 
Kleptomania: take something for it.

Attachment: pgpwD6DuHQwtN.pgp
Description: PGP signature