Tugger the SLUGger!SLUG Mailing List Archives

RE: [SLUG] SAMBA sharename problem


OK, I'm running SAMBA as a daemon. If you are running it through inetd, the
netbios service probably won't appear until inetd switches it in for the
particular session.
The other thing you probably need to set in smb.conf is the IP address of
your local WINS server.
And set wins support to "no" if there is an NT box out there doing WINS
services for the blighters.
 wins server = 192.168.34.3
 wins support = no

The SAMBA doco says that only one WINS server can exist on a network (I
think this is decided during those election thingys), so if by some chance
you have set
 wins support = yes
on your Linux box, then it must be "no" on other machines.

Do you have SWAT installed (runs on port 901, try http://myserver:901 ) ?
It has the online docs. Login / password required.

Regards,

Jill.

___________________________________________
Jill Rowling
Snr Design Engineer & Unix System Administrator
Electronic Engineering Department, Aristocrat Technologies Australia
3rd Floor, 77 Dunning Ave Rosebery NSW 2018
Phone:	(02) 9697-4484		Fax:	(02) 9663-1412
Email:	rowling@xxxxxxxxxx
 


-----Original Message-----
From: Alister Waller [mailto:alister@xxxxxxxxxxxxxxxxxxxxxx]
% ./smbclient -L MACHINE_NAME -U '' -N
I get:
session request to xxx failed    (xxx = machine name)
session request to *SMBSERVER failed

when I run:
% ps -auwwx | grep mbd
It works OK.....I can see the smbd and nmbd processes.

when I run:
netstat -a | grep netbios
I get NOTHING.

upon investigation I looked at netbios and tried to start it but it gave an
error about an IP address so I looked at the nbconf file which seemed like
it had the wrong IP address in it so I changed this to be correct and also
the broadcast one.

now when i /etc/netbios start
I get:
starting netbios: nbd: Can't open Netbios device: No Such file or Directory