Tugger the SLUGger!SLUG Mailing List Archives

[SLUG] modprobe woes


running debian slink

i have two intel etherexpresses, but cant seem to get them working at the same time. this is a run down of what ive done

in /etc/modutils/aliases

alias eth0 eexpress
alias eth1 eexpress
options eth0 -o eexpress-0 io=0x270 irq=5
options eth1 -o eexpress-1 io=0x300 irq=10

then i run

update-modules
modprobe -r eexpress
modprobe -a /lib/modules/2.0.38/net/e*

but only one will ever be running. i can get the both cards up individually, ping other hosts etc, just not at the same time .. very frustrating :/

ive tried "options eexpress io=0x270,0x300 irq=5,10" and an append line similar to that in /etc/lilo.conf, still the same problem of only one working. one odd thing i noticed was in a modprobe -c there's "alias eth0 off" nfi what its doing or how it got there, it's not in /etc/conf.modules or /etc/modutils/*

im not too familiar with debian, maybe im missing something?

cheers
pete
________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com