Tugger the SLUGger!SLUG Mailing List Archives

[SLUG] Help with conf.modules


Hi,
I recently installed an ISA NE2000 into a Pentium II that contained an Intel eepro100. I got both cards going, got the cable modem connected to the ne, and ran dhcpcd. Everything was working fine. After a reboot, I have two problems. One is that neither of the NIC's is brought up at startup, despite these lines in /etc/conf.modules:

alias eth0 eepro100
alias eth1 ne
options ne io=0x240 irq=3

I know that the 8390 module is required to use the ne, so I am suspecting that it has to be inserted into this file for the ne to be brought up successfully, maybe appended to the second line? However, this still doesn't explain the eepro100 not being loaded in. My second problem is that once I do insert the modules manually, I can configure both cards and see the network, but I can't get dhcpcd to assign the ne's IP address. After running it:

dhcpcd -h <hostname> interface eth1

it seems to run and exit (or fork(), whatever it does) successfully, but checking ifconfig shows the interface remains unchanged. Mind you, this command worked flawlessly previously.

I would appreciate any help at all on this matter.
Thanks,
Alex
________________________________________________________________________
Get Your Private, Free E-mail from MSN Hotmail at http://www.hotmail.com