Tugger the SLUGger!SLUG Mailing List Archives

[SLUG] Thank you all


Thankyou to all who gave me advice etc. regarding my query about
partition tables and formatting my D: drive under Win 98 and ftping and
finding fdisk & cfdisk.

I tried to format the D: drive under WIN 98 but it wouldn't format. DOS
fdisk showed everything as being in the right place etc. Linux's cfdisk
showed everything as being OK and that the win D: drive (hda7 under
Linux) was there as a dos logical partition type  dos 16 bit so, in I
went, boots and all, and changed the type to 0c to be the same as cfdisk
said hda1(the win C: drive) was, (It actually said it was WIN 95 FAT 32
(LBA) which equated to 0c in the table that is thrown up) and wrote it!

The end result is that WIN98 is gone, it's there but the directory
entries are all stuffed up, all funny chars. I could get to the D: drive
OK and I managed to format it OK.

On a reboot Linux came up as normal (I'm in Linux Netscape now) but
entering dos at the Lilo prompt elicited a 'dunno wot yore talking
about' message.

When I tried to mount the WIN D: drive using 'mount -t vfat /dev/hda7
/mnt/ddrive' I received the following message:- mount: wrong fs type,
bad option, bad superblock, or too many mounted file systems. Using the
same mount command I can mount /dev/hda1 OK (from a terminal) but an ls
-l gives some funny results.

I'm not too worried about having to re-install WIN 98 (A Windows user
gets LOTS of practice installing the OS) In fact, if it wasn't for the
fact Linux cannot find a parallel port I wouldn't bother re-installing
Windows. Which brings me to the next question.

I ran printtool to set up a printer but it said Auto-detection found the
following: 

/dev/lp0 : Not detected  (and the same for /dev/lp1 & /dev/lp2) ... and
this could indicate a hardware problem that justifies further
investigation. 

The port works under WIN 98 just fine so the problem is in how I've got
Linux set up. I installed printer support during installation. Doing a
'dmesg | grep lp' to find out what port the driver found elicited
nothing. I then thought the driver may not be loaded so I did a
'/sbin/modprobe lp' and then tried printtool again. Still nothing.

Does anyone have any idea what I've done wrong printing wise. btw, if I
ignore the message about no ports I can continue with printtool to set
up a printer but, of course, I cannot print.

Sorry to be a PITB but thanks in advance,

-- 
Regards,


Graeme Nichols.