Tugger the SLUGger!SLUG Mailing List Archives

[SLUG] IDE cdrom gone AWOL


Sluggers,

I just tried to upgrade from deadrat 6.1 to 6.9. Seemed to go ago but
crashed with a few rpms still not installed. Re-ran the install and it
crashed again in the same place. I managed to get the system back on
it's feet and it has been running for about a week now. All is fine 
except I can't mount the cdrom drive. It's the primary on the first
IDE, (hard disks are scsi). Shows up in the Bios ok, and the system
will boot from a cd so hardware is fine. Any ideas where to start?

(install Debian comments already taken on notice, but thanks anyway ;-)

Appropriate lines from /var/log/dmesg

  PIIX4: IDE controller on PCI bus 00 dev 21
  PIIX4: not 100% native mode: will probe irqs later
    ide0: BM-DMA at 0x1860-0x1867, BIOS settings: hda:DMA, hdb:DMA
    ide1: BM-DMA at 0x1868-0x186f, BIOS settings: hdc:pio, hdd:pio
  hda: HITACHI CDR-8435, ATAPI CDROM drive

Other stuff....

 % mount /mnt/cdrom
  mount: wrong fs type, bad option, bad superblock on /dev/cdrom,
       or too many mounted file systems
       (aren't you trying to mount an extended partition,
       instead of some logical partition inside?)

 % grep cdrom /etc/fstab
  /dev/cdrom       /mnt/cdrom         iso9660 noauto,owner,ro 0 0

 % ls -l /dev/cdrom
  lrwxrwxrwx    1 root     root            3 Mar 29 22:56 /dev/cdrom -> hda

 % ls -l /dev/hda
  brw-rw----    1 root     disk       3,   0 Jul 22 00:29 /dev/hda

 % cat /proc/ide/ide0/hda/driver
  ide-cdrom version 4.58

 % cat /proc/ide/ide0/hda/media
  cdrom

 % cat /proc/ide/ide0/hda/model
  HITACHI CDR-8435

Kernel is 2.2.16-17smp, 
though I've only got the one processor :-( 


Thanks

Pete