Tugger the SLUGger!SLUG Mailing List Archives

[chat] Re: Cisco 827 config (replacing DLink DSL300+)


John Clarke <johnc@xxxxxxxxxxx> uttered the following thing:
> Hi all,
> 
> I need some help configuring a Cisco 827.  I'm currently using a DLink
> DSL300+ ADSL modem and would like to configure the 827 as a drop-in
> replacement.
> 

As far as I know, a Cisco 827 can only do half-bridge if the
DSLAM/NRP/RAS supports PPPoE. For PPPoA, the best you can do is 
nat default inside server.

This my config. The internal box gets a 192.168 address, and I don't
have any problems with this setup. Some qus and ipv6 is thrown in also.

BB

!
class-map match-all udp
  match access-group 151
class-map match-any diffserv
  match  dscp ef 
  match  dscp af31 
  match  dscp af11 
class-map match-any highprio
  match class-map udp
  match class-map diffserv
  match class-map tcpack
class-map match-all bulk
  match access-group 152
!
policy-map policy
  class highprio
   priority 84
  class bulk
   bandwidth 192
   random-detect
!
! 
ip dhcp excluded-address 192.168.1.1 192.168.1.99
!
ip dhcp pool cactii
   network 192.168.1.0 255.255.255.0
   domain-name cactii.net
   default-router 192.168.1.1 
   dns-server 192.168.1.2 202.154.83.53 
!
ipv6 unicast-routing
!
interface Ethernet0
 ip address 192.168.1.1 255.255.255.0
 ip nat inside
 ipv6 address 2001:388:C021::2/64
 ipv6 enable
 ipv6 nd prefix 2001:388:C021::/48
 hold-queue 100 out
!
interface ATM0
 no ip address
 no atm ilmi-keepalive
 dsl operating-mode auto
!
interface ATM0.3 point-to-point
 description 1500/256k ADSL
 pvc 8/35 
  random-detect
  ubr 256
  encapsulation aal5mux ppp dialer
  dialer pool-member 1
 !
!
interface Dialer1
 bandwidth 240000
 ip address negotiated
 ip nat outside
 encapsulation ppp
 dialer pool 1
 dialer-group 1
 ppp chap hostname <blah>
 ppp chap password <blah>
 service-policy output policy
!
ip nat inside source list 101 interface Dialer1 overload
! Add more of these lines below for inbound port forwarding
! Or use the nat default inside server feature, see
! http://www.cisco.com/univercd/cc/td/doc/product/software/ios122/122newft/122t/122t13/ftnatis.htm
ip nat inside source static tcp 192.168.1.2 80 interface Dialer1 80
ip nat inside source static tcp 192.168.1.2 25 interface Dialer1 25
ip nat inside source static tcp 192.168.1.2 22 interface Dialer1 22
ip classless
ip route 0.0.0.0 0.0.0.0 Dialer1
!
access-list 101 permit ip 192.168.1.0 0.0.0.255 any
access-list 151 permit udp any any
access-list 151 permit icmp any any
access-list 151 deny ip any any
access-list 152 permit tcp any any established
access-list 152 deny  ip any any
!
dialer-list 1 protocol ip permit
!